Radio Not Working - Maserati Ghibli Forum
User Tag List

 1Likes
Reply
 
LinkBack Thread Tools Search this Thread
post #1 of 22 (permalink) Old 01-14-2014, 09:06 AM Thread Starter
Junior Member
 
Join Date: Jan 2014
Location: Miami
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Radio Not Working

Hi is anyone having issues with the radio? For the 3rd time, my car radio will not work, it shows its on i tried fm, sat, cd nothing worked, but it would show on the screen that it was on and volume would go up in number, bu NO SOUND!!! the weirdest part is on the way home for the last 2 days it works fine.... It looks like its the radio amp, becasue not even sound for the phone blue tooth or parking sensors would work..
verstraaten likes this.
AGMIA is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 01-14-2014, 01:05 PM
Senior Member
 
Join Date: Jul 2013
Posts: 112
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
you could try a reset back to factory settings? No guarantees, but I'ze seen that fix many issues in the past...
ghibless is offline  
post #3 of 22 (permalink) Old 02-03-2014, 09:30 PM
Junior Member
 
Join Date: Feb 2014
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi AGMIA,

I have a 2014 Q4 S that has the same issue. There are sound about 50% of the time when I start the car, and the other 50%, I hear nothing from the radio, CD player or phone, but the climate control works and all other controls are fine. My dealer in Charlotte, NC says it is the 'amplifier' and has ordered a new one from Italy. I don't know what an amplifier is, but it sounded like my dealer knew this righ-away without even seeing the car (we talked over the phone). So, you can ask your dealer if they know if this is the issue in your car also...
bberg is offline  
 
post #4 of 22 (permalink) Old 02-05-2014, 06:14 PM
Senior Member
 
Join Date: Jan 2014
Posts: 113
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
In talking with my dealer today about the issues I am having with satellite radio drop outs, he said that the amp is actually a Bowers & Wilkins amp. I had no idea they made amps - I thought just speakers? Apparently all 3 versions of the sound system are OEM from B&W. Anyway, I'm getting a new amp/head unit because of the satellite issue. The dealer said they have already replaced one other customers so apparently there are known problems with the amps. He also said they would "reseat" and seal the subwoofer speaker so hopefully that will improve the sound quality. Honestly if I were B&W, I would not want my name associated with the current quality of the sound in the car. My kid's boom box sounds better than this!
cfelbab is offline  
post #5 of 22 (permalink) Old 02-09-2014, 09:46 PM
Junior Member
 
Join Date: Feb 2014
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Counted the number of times acquiring signal popped up on trip from mass to NYC. Stopped when I got to 100. Frustrated.
Dfarns is offline  
post #6 of 22 (permalink) Old 02-10-2014, 08:12 AM
MGE
Junior Member
 
Join Date: Jan 2014
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by cfelbab View Post
In talking with my dealer today about the issues I am having with satellite radio drop outs, he said that the amp is actually a Bowers & Wilkins amp. I had no idea they made amps - I thought just speakers? Apparently all 3 versions of the sound system are OEM from B&W. Anyway, I'm getting a new amp/head unit because of the satellite issue. The dealer said they have already replaced one other customers so apparently there are known problems with the amps. He also said they would "reseat" and seal the subwoofer speaker so hopefully that will improve the sound quality. Honestly if I were B&W, I would not want my name associated with the current quality of the sound in the car. My kid's boom box sounds better than this!
your dealer is way off base with the satellite fix... are you sure thats what they are going to do? Its an antenna issue not a head unit or amp issue. On mine they just needed to replace the antenna with a different one and the problem is gone. I also had that subwoofer fix performed on my car it makes it a little better but not much. The problem with the sub and the entire system is its just junk. How they could of put such sub-par product in this car is embarrassing.
MGE is offline  
post #7 of 22 (permalink) Old 02-10-2014, 11:13 AM
rsm
Senior Member
 
rsm's Avatar
 
Join Date: Oct 2013
Posts: 324
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Quote:
The problem with the sub and the entire system is its just junk. How they could of put such sub-par product in this car is embarrassing.
It's one of the cost cutting measures to keep the price lower. Either you accept that if you want the low price or you believe Maserati should properly outfit the ghibli and raise the price accordingly. I'm of the latter camp.
rsm is offline  
post #8 of 22 (permalink) Old 02-10-2014, 12:37 PM
Senior Member
 
Join Date: Jun 2013
Posts: 284
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
i rather they cheap out on the audio system than any other part of the car.
plus i never like factory audio systems, rather install something more to my liking
ratti is offline  
post #9 of 22 (permalink) Old 02-10-2014, 02:31 PM
Senior Member
 
Etodd31856's Avatar
 
Join Date: Sep 2013
Location: Central NJ, USA
Posts: 852
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 62 Post(s)
agreed but for 1K+ sounds like it should have been better......but that is not what we are buying.......
Etodd31856 is offline  
post #10 of 22 (permalink) Old 02-10-2014, 07:18 PM
MGE
Junior Member
 
Join Date: Jan 2014
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
then they shouldn't charge extra for it and call it a "premium" system if its the "cost-cutting" system. That doesn't make sense. I've rented sub 20k economy cars before with way better stereos. I don't believe they meant for it to be this poor.
MGE is offline  
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Optimization by vBSEO 3.6.1 ©2011, Crawlability, Inc.