2017 Ghibli SQ4 and iPhone 7+ woes - Maserati Ghibli Forum
User Tag List

 
LinkBack Thread Tools Search this Thread
post #1 of 3 (permalink) Old 02-27-2017, 06:14 PM Thread Starter
Junior Member
 
Join Date: Feb 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Unhappy 2017 Ghibli SQ4 and iPhone 7+ woes

I am having difficulty with the iPhone integration with my Ghibli. For example, here is a problem that I had today:
I was driving home with the phone plugged in and using Apple CarPlay, I was able to make the first call. Then my wife called me back and I was unable to hear her either on the car speaker or on the phone. I tried to call her back and could hear the phone ringing over the car speakers but, as soon as she answered the phone, the audio went out and I could not hear the audio from the car or the phone.

I unplugged the phone and was able to call her back. However, unplugging the phone seems to have changed the temperature units for the A/C but not for the outside temperature. See attached picture.
I have been having similar challenges with the bluetooh integration. The first time I make/receive a call, the car prompts me as to whether I want to transfer the call to Hands Free mode (or something like that). Regardless of whether I select Yes or No, the audio is transferred to the phone and I have to press the "Transfer Back" button on the console to be able to hear the caller. That means that I have to press three buttons for the first incoming call. Really? I drove BMWs for 20 years and have used multiple iphones with various models but never had a problem.

The dealer is trying to tell me it is an iPhone problem but since the same phone works perfectly in my X5 and my Honda Odyssey, I don't see how this isn't a Maserati problem...
rhpatrick is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-06-2017, 01:05 PM
Banned
 
Join Date: Mar 2017
Location: Colorado
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Yes.. I know that iphones have this problem..
Elan is offline  
post #3 of 3 (permalink) Old 03-17-2017, 12:41 PM
kc1
Junior Member
 
Join Date: Mar 2017
Location: NELA
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Were the BMW and Honda both running Apple CarPlay?

It's time to upgrade to a Nokia, IMO! (https://www.nokia.com/en_int/phones/nokia-3310)
kc1 is offline  
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Optimization by vBSEO 3.6.1 ©2011, Crawlability, Inc.