Maserati Ghibli Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2017 SQ4 that I bought as soon as it came out last Oct. I love it but it’s had a few issues. The most frequent problem is with the infotainment system. Currently it’s stuck in “downloading hands free” and even with a factory reset it’s not working. Because of this most of the rest of it’s not working including nav, music and phone. The uconnect website does not support Maserati. Is anybody having issues or can help? Even if there is a number I can call that would be great. I just had it in the shop for a week a month ago so I would like to avoid that if possible.
 

·
Registered
Joined
·
61 Posts
I have a 2017 SQ4 that I bought as soon as it came out last Oct. I love it but it’s had a few issues. The most frequent problem is with the infotainment system. Currently it’s stuck in “downloading hands free” and even with a factory reset it’s not working. Because of this most of the rest of it’s not working including nav, music and phone. The uconnect website does not support Maserati. Is anybody having issues or can help? Even if there is a number I can call that would be great. I just had it in the shop for a week a month ago so I would like to avoid that if possible.
My infotainment system was acting up. It needed a software update. 30 minutes at the dealer and everything was fine.
 

·
Registered
Joined
·
644 Posts
I have a 2017 SQ4 that I bought as soon as it came out last Oct. I love it but it’s had a few issues. The most frequent problem is with the infotainment system. Currently it’s stuck in “downloading hands free” and even with a factory reset it’s not working. Because of this most of the rest of it’s not working including nav, music and phone. The uconnect website does not support Maserati. Is anybody having issues or can help? Even if there is a number I can call that would be great. I just had it in the shop for a week a month ago so I would like to avoid that if possible.
possible software updates are one solution, if applicable. an alternative is something corrupted within the Bluetooth functionality, may need replacement.
i had this occur on a PDI car once, after hard resetting the battery and letting it fully load up for an unknown amount of time before trying to pair a phone for the first time, all was kosher.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
I took the car to the dealer and none of the hard resets worked.They have to replace the whole system. I'm waiting for the parts to come in. This is the fourth time I have had issues so hopefully this is a permanent fix.
 

·
Registered
Joined
·
29 Posts
I took the car to the dealer and none of the hard resets worked.They have to replace the whole system. I'm waiting for the parts to come in. This is the fourth time I have had issues so hopefully this is a permanent fix.
If this is the 4th time then your entitled to pursue the lemon law. I pursued it, settled for an undisclosed amount of money AND they fixed the infotainment system finally.

Don’t ever settle for anything less than what you deserve or less than what you paid for.
 
1 - 5 of 5 Posts
Top