Maserati Ghibli Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi Everyone,


I had a great 2014 SQ4 and now got an incredible 2018 SQ4. I will do a review comparison of each when I free up some time. My 2014 was an amazing car, but the 2018 is on another level!

I have had the 2018 for 10k already.

I use apple carplay everytime I’m in the car and one of every 15-20 calls goes mute when I call someone or even during the call. When it happens I need to unlplug the phone and use it manually. Its quite annoying and dangerous while driving of course.

Dealer updated all software and no codes or errors are appearing. I tried different USB cables and 3 different iPhones and it makes no difference. Random and intermittent.

Is anyone using Apple CarPlay non stop and having a similar intermittent issue like this or is anyone’s flawless?

Dealer told me they havent seen it elsewhere but admit that there aren’t that many on the road and most users aren’t “power” users.

Software glitch I live with or force them to replace hardware with all the pain that entails?

Thanks in advance!
 

·
Registered
2014 GT MC / 2018 Ghibli SQ4 Gransport
Joined
·
376 Posts
Is anyone using Apple CarPlay non stop and having a similar intermittent issue like this or is anyone’s flawless?

Dealer told me they havent seen it elsewhere but admit that there aren’t that many on the road and most users aren’t “power” users.

Software glitch I live with or force them to replace hardware with all the pain that entails?

Thanks in advance!
It's definitely not flawless for me. I also have a 2018 and use Carplay almost every day. Not so much to make/take phone calls, but more so to stream spotify, use navigation, and dictate/listen to text messages. I've had my 2018 for 7 months and in that time, the carplay failed to even open twice. I unplugged it and plugged it back in while the car was still on and nothing. After shutting down the car and restarting, it was fine. Also on occasion spotify freezes or audio quality gets worse so I have to unplug the USB and then plug it back in to reboot carplay/spotify which usually does the trick. I'd say overall, it works like it should 95% of the time for me. The voice recognition for Siri, Waze, and Googlemaps all work very well and I've had no issues there. So except for the two times where it wouldn't even load, unplugging the usb and plugging back in fixed any issues.
 

·
Registered
Joined
·
36 Posts
Hi.
I don’t even use car play often, but once i did, it completely freezes the mtc and anything left was a dark screen and an annoying cracking noise came out of the speakers.. few minutes later mtc rebooted itself and everything was fine again. I didn’t try it again so far. But I don’t know what the advantage of car play is: everything it does the mtc does too, except reading messages. Streaming, Navigation, Phone calls etc.
Most of the time I’m using the SD-Card for playing music, which works very good.

And even I don’t like the look of the huge app-Symbols: looks like a Smartphone for my grandma...

Daynie


Gesendet von iPhone mit Tapatalk Pro
 

·
Registered
Joined
·
61 Posts
I use CarPlay regularly. The Maps navigation is far superior to the built in navigation (MY 2017). The music sounds better than over bluetooth. I use iHeart Radio for satellite radio quality local AM broadcasts. I also prefer the interface. Although I agree it is not flawless. If the phone is connected before I start ignition, the car does not recognize the phone. I need to disconnect and reconnect. Also, sometimes even if I connect after starting ignition, it will not recognize the phone. I may have to disconnect and reconnect the phone once or twice. Once connected, I have not had any problems like you describe. However, I don't think I ever made 15 calls on a single drive.

This behavior of my Maserati is the same with my other cars equipped with CarPlay. It might be finicky in connecting, but once connected, it works well.

When I first bought the car, CarPlay was a dumpster fire. I could rarely get it to connect. The MTC+ would reboot, I might even lose my back-up camera. But a software update while I waited fixed all of that.
 

·
Registered
Joined
·
88 Posts
I use CarPlay regularly. The Maps navigation is far superior to the built in navigation (MY 2017). The music sounds better than over bluetooth. I use iHeart Radio for satellite radio quality local AM broadcasts. I also prefer the interface. Although I agree it is not flawless. If the phone is connected before I start ignition, the car does not recognize the phone. I need to disconnect and reconnect. Also, sometimes even if I connect after starting ignition, it will not recognize the phone. I may have to disconnect and reconnect the phone once or twice. Once connected, I have not had any problems like you describe. However, I don't think I ever made 15 calls on a single drive.

This is basically my experience with my 2017.

The only new issue I have currently is after getting my screen replaced under warranty last week, when I get a notification like a text message the volume of the sound for the notification is very low. Previously it was loud. The volume is all the sway up on the Car system and on my phone though. I must be missing something as this was never an issue before for me.
 

·
Registered
Joined
·
6 Posts
Hi Everyone,


I had a great 2014 SQ4 and now got an incredible 2018 SQ4. I will do a review comparison of each when I free up some time. My 2014 was an amazing car, but the 2018 is on another level!

I have had the 2018 for 10k already.

I use apple carplay everytime I’m in the car and one of every 15-20 calls goes mute when I call someone or even during the call. When it happens I need to unlplug the phone and use it manually. Its quite annoying and dangerous while driving of course.

Dealer updated all software and no codes or errors are appearing. I tried different USB cables and 3 different iPhones and it makes no difference. Random and intermittent.

Is anyone using Apple CarPlay non stop and having a similar intermittent issue like this or is anyone’s flawless?

Dealer told me they havent seen it elsewhere but admit that there aren’t that many on the road and most users aren’t “power” users.

Software glitch I live with or force them to replace hardware with all the pain that entails?

Thanks in advance!

I have the same issue on my 20 Ghibli
 

·
Registered
Joined
·
4 Posts
It's definitely not flawless for me. I also have a 2018 and use Carplay almost every day. Not so much to make/take phone calls, but more so to stream spotify, use navigation, and dictate/listen to text messages. I've had my 2018 for 7 months and in that time, the carplay failed to even open twice. I unplugged it and plugged it back in while the car was still on and nothing. After shutting down the car and restarting, it was fine. Also on occasion spotify freezes or audio quality gets worse so I have to unplug the USB and then plug it back in to reboot carplay/spotify which usually does the trick. I'd say overall, it works like it should 95% of the time for me. The voice recognition for Siri, Waze, and Googlemaps all work very well and I've had no issues there. So except for the two times where it wouldn't even load, unplugging the usb and plugging back in fixed any issues.
Yes I am having the exact same issues. The dealership says it’s my cord, but I have purchased three from Apple, with the same results. Very disappointed, and yes dangerous also. I’d go as far to say that I have lost business due to this issue as being in Real Estate, it’s all about speed to lead! A very frustrating issue, hoping Maserati can address it for us soon. Otherwise, I’m in love with my Ghibli. But won’t buy another if this issue doesn’t get resolved.
 

·
Registered
Joined
·
6 Posts
Yes I am having the exact same issues. The dealership says it’s my cord, but I have purchased three from Apple, with the same results. Very disappointed, and yes dangerous also. I’d go as far to say that I have lost business due to this issue as being in Real Estate, it’s all about speed to lead! A very frustrating issue, hoping Maserati can address it for us soon. Otherwise, I’m in love with my Ghibli. But won’t buy another if this issue doesn’t get resolved.
We were having issues with our 20 SQ4, however problem fixed when I turned on the car, unlocked my phone, bluetooth turned on and then connected the phone via the Apple approved cable.
 

·
Registered
Joined
·
9 Posts
Hi Everyone,


I had a great 2014 SQ4 and now got an incredible 2018 SQ4. I will do a review comparison of each when I free up some time. My 2014 was an amazing car, but the 2018 is on another level!

I have had the 2018 for 10k already.

I use apple carplay everytime I’m in the car and one of every 15-20 calls goes mute when I call someone or even during the call. When it happens I need to unlplug the phone and use it manually. Its quite annoying and dangerous while driving of course.

Dealer updated all software and no codes or errors are appearing. I tried different USB cables and 3 different iPhones and it makes no difference. Random and intermittent.

Is anyone using Apple CarPlay non stop and having a similar intermittent issue like this or is anyone’s flawless?

Dealer told me they havent seen it elsewhere but admit that there aren’t that many on the road and most users aren’t “power” users.

Software glitch I live with or force them to replace hardware with all the pain that entails?

Thanks in advance!
I’ve got a 17. Same issue. It’s very frustrating. I can make a call and all is well. 10 mins later answer an incoming call and I can hear them but they can’t hear me. It’s random. Doesn’t seem to matter if the car is on or off when I connect the phone. BT works perfect. It’s the car play that sucks. Also if I listen to a podcast it seems to pause and play throughout the show!
 
1 - 10 of 10 Posts
Top