Maserati Ghibli Forum banner

21 - 23 of 23 Posts

Registered
Joined
436 Posts
My 2017, I disabled it via the MTC+, it has never worked since day one.
I disabled it before the car left the showroom.
It has never worked in 3 years.
 

Registered
Joined
3 Posts
I learned the hard way about the battery, about 3 months into owning my 2015. Letting it sit like a trophy in the garage, quickly led to a dead battery. The cluster panel went nuts, and the wipers came on as you stated. I was able to jump it off and let my wife drive it (her car). Not long after, it did it again, and the battery would not recover, nor could I successfully jump it off. I ended up replacing the battery, and buying a trickle charger for it, with a digital display showing % charged. It's amazing how fast it will go down if you let it sit. Wish I would have bought the charger when I first bought the car. Hard lesson learned. I ended up with an aftermarket battery for the replacement, and kept the factory one for a shelf display. :)
 

Registered
Joined
18 Posts
My 2017, I disabled it via the MTC+, it has never worked since day one.
I disabled it before the car left the showroom.
It has never worked in 3 years.
Same is mine 2017. I never enabled the StartStop. It's always and permanently off. As mentioned before i also dislike the yellow "A" which tries to remind you that the function is disabled.
It maybe restarts itself when battery ist completely dead during starting or if it is replaced or disconnected...



Gesendet von iPhone mit Tapatalk Pro
 
21 - 23 of 23 Posts
Top