Maserati Ghibli Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter #1
Today when driving the car fairly hard in sport mode (automatic) the check engine light started flashing. Car seemed a bit sluggish after that. I stopped the car and restarted it and now the check engine light is on steady but the car appears to be working fine. I had it in a couple of weeks ago and they supposedly did all the service repairs including the one with the spark plugs that i have read people say might have caused engine issues. Anybody else having this issue? Is there a way to get the car to tell me what it thinks is going on without the dealer?

I am going to call the dealer Monday. The car was scheduled to go back in for a third attempt at the subwoofer on October 8th. I am not excited about having to bring the car in before that...

Does anybody know if it is a terrible thing to drive the car with the CEL on?
 

·
Registered
Joined
·
41 Posts
Today when driving the car fairly hard in sport mode (automatic) the check engine light started flashing. Car seemed a bit sluggish after that. I stopped the car and restarted it and now the check engine light is on steady but the car appears to be working fine. I had it in a couple of weeks ago and they supposedly did all the service repairs including the one with the spark plugs that i have read people say might have caused engine issues. Anybody else having this issue? Is there a way to get the car to tell me what it thinks is going on without the dealer?

I am going to call the dealer Monday. The car was scheduled to go back in for a third attempt at the subwoofer on October 8th. I am not excited about having to bring the car in before that...

Does anybody know if it is a terrible thing to drive the car with the CEL on?
Mine came on and stayed on for about a day and went away. I was ready to call service, but it turned off. I think the car is pretty intelligent and can fix itself sometimes. Wait one more day and if it's still on, call service.
 

·
Registered
Joined
·
17 Posts
The check engine light is there for a reason - if it comes on in my car i'm not driving it and i'm going into service reagrdless...
 

·
Administrator
Joined
·
2,410 Posts
Today when driving the car fairly hard in sport mode (automatic) the check engine light started flashing. Car seemed a bit sluggish after that. I stopped the car and restarted it and now the check engine light is on steady but the car appears to be working fine.

The car was scheduled to go back in for a third attempt at the subwoofer on October 8th. I am not excited about having to bring the car in before that...

Does anybody know if it is a terrible thing to drive the car with the CEL on?
Some of the CEL codes will clear (turn off) by themselves on the next cycle ... like bad gasoline or air leak through gas cap seal. Others that are coded as a more serious "event" will stay on until cleared by dealer.
 

·
Registered
Joined
·
114 Posts
Discussion Starter #5
Some of the CEL codes will clear (turn off) by themselves on the next cycle ... like bad gasoline or air leak through gas cap seal. Others that are coded as a more serious "event" will stay on until cleared by dealer.
Well I called the dealer this morning since the light was still on and they said they wanted to check it out even though everything else seems normal. To their credit, they brought over to my work another Ghibli and swapped it with me while they take the car and sort out what is happening (and hopefully also fix the subwoofer issue once and for all). It was a sweet sight in front of my office building to see two blue ghibli's parked one behind another as we did the exchange!

While having the other (somewhat newer I think) car, I tried to get the subwoofer to rattle and even by pushing it hard and loud it did not so I do believe that the sound can be made to work. In fact, I would say that the sound overall in this car was much better so it is possible to get a passable sound system in the car. The difference was that without the rattle you can crank the bass up enough to make up for much of the issues.

As for the more serious CEL issue, hopefully I will have an answer in a day or two. In the meantime, I will drive the dealer's Maserati....
 

·
Administrator
Joined
·
2,410 Posts
ceflbab - Hopefully they will find something simple. To Jackal's comments you already had the plugs replaced once. If it turns out to be a misfire and new plugs again ... something else is going on with these engines. cflbab - Is yours an S-Q4?
 

·
Registered
Joined
·
114 Posts
Discussion Starter #8
ceflbab - Hopefully they will find something simple. To Jackal's comments you already had the plugs replaced once. If it turns out to be a misfire and new plugs again ... something else is going on with these engines. cflbab - Is yours an S-Q4?
They were vague about what caused the issue but they did replace the spark plugs. Not sure if this is going to fix the problem long term or not but they did actually finally get the subwoofer fix done to my satisfaction. No rattles and now I can amp up the bass enough to compensate for the general weakness of the sound system. In fact, it is almost a decent sounding system now. Not better than what I had my BMW but passable. Happy with that.

Yes, a SQ4. One of the very early ones - I took possession on 1/1/14 so it was clearly one of the first few batches made.

This car is quite the paradox. Two days ago I was sitting at the gas station putting fuel in the car hoping that would cause the CEL to go off and feeling a bit frustrated with the whole deal. While standing at the pump, a guy comes up to me and asks if he can take a picture of the car...
 

·
Administrator
Joined
·
2,410 Posts
The dynamat in back deck definitely makes a nice difference in the base sound quality. They did my car even though the subwoofer rattle was not present. It seemed to go away in warm weather but dealer was being thorough.

I have a 12/13 build date and so far it is not worse or better than any other new car I've had with regard to minor fixes.

To your comment ... IT IS THE MOST ADMIRED NEW CAR I HAVE EVER HAD. You'd think I was driving a Bugatti when folks stop to admire or take pictures.
 

·
Registered
Joined
·
236 Posts
Sorry, I missed the spark plugs in the OP. My second CEL was still a misfire. They found no cause so did nothing. Interesting that they replaced the spark plugs for you again. The diagnosis should be printed on your service receipt.
 

·
Registered
Joined
·
114 Posts
Discussion Starter #11
Sorry, I missed the spark plugs in the OP. My second CEL was still a misfire. They found no cause so did nothing. Interesting that they replaced the spark plugs for you again. The diagnosis should be printed on your service receipt.
It looks like the first time they just "cleaned and tightened" the spark plugs. Supposedly a standard thing they were doing when the car came in for anything. At that point, I had not encountered the CEL issue so there was probably no reason for them to do more. Now today after the CEL issue they replaced the plugs.

I may have spoke too soon about the subwoofer fix. It is much better but there are still some songs than sound horrible. The "royals" song (Lorde or something) has a lot of bass and when I turn that song up it sounds like the car is farting more than playing music and the rattle is there. Still, for nearly everything else it sounds much better.
 

·
Registered
Joined
·
36 Posts
cfelbab,
Were they able to fix the check engine light issue after all this time?

For the second time, the check engine light shows up on my Ghibli Q4 and they will try to fix it for the third time...My car has 600 miles... :(
 
1 - 12 of 12 Posts
Top