Maserati Ghibli Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter · #1 ·
On a recent trip to Cornwall the Cruise Control played up. About 2 hours into the return journey it was set to 68mph. I had braked then pressed the resume switch (upwards). The orange symbol briefly went green then back to orange. After another press it went green showing 0mph then orange.
Switching the Cruise Control off/on made no difference. Only when I switched the engine off at a service area did it reset itself and work again. No problem since.
I'll report it at the first service.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
14 Posts
On a recent trip to Cornwall the Cruise Control played up. About 2 hours into the return journey it was set to 68mph. I had braked then pressed the resume switch (upwards). The orange symbol briefly went green then back to orange. After another press it went green showing 0mph then orange.
Switching the Cruise Control off/on made no difference. Only when I switched the engine off at a service area did it reset itself and work again. No problem since.
I'll report it at the first service.
Sent from AutoGuide.com Free App
My "up" button only works sporadically. Most of the time ti cancels cruise -- i.e. turns it off (orange symbol goes away; no green symbol; msg in display says cruise is off). It's so aggravating that I just don't use "resume" any more, I just reset cruise speed. I plan also to report at the first service.
 

·
Registered
Joined
·
216 Posts
I noticed the exact same behaviour as MORPAUL. I told my dealer. I cannot reproduce, but suddenly it is there. In most times it works. It crashes in longer journeys (>1h).

Tell this your dealer. This seems to be a SW bug. So we can pray for a fix.
 

·
Registered
Joined
·
292 Posts
I have the same issue. I have had the dealership look at this issue and they couldn't replicate it either. I drove the car with the Service Advisor and was able to replicate it for him. It is a real pain when trying to use the resume feature. My car goes back in on Wednesday, and I will have them look at it again.
 

·
Registered
Joined
·
292 Posts
how can you replicate / reproduce? I would like to show my dealer.
I was fortunate enough to have it happen with him in the car. It had never worked properly when I dropped it off. When he called to tell me it was okay, I immediately drove down there and proved to him what was happening. On the drive with him, it actually worked correctly a couple of times.....
 

·
Registered
Joined
·
695 Posts
I know this is bad but have yet to use cruise in 6 months. May have to take ride to Nev. stateline to buy lottery tickets (47 miles) to see if I have problem.
 

·
Administrator
Joined
·
2,521 Posts
bjg625: Your not the only one ... I haven't used the cruise control since buying the car 6-months ago.
 
1 - 8 of 8 Posts
Top