Maserati Ghibli Forum banner

81 - 100 of 125 Posts

·
Super Moderator
Joined
·
2,100 Posts
I can say the reverse for sure. The SQ4 tune will not work on the base ... that has been proven since the engine parameters are different.
That said, I would not expect a proper "base" tune to work on an SQ4.
 

·
Registered
Joined
·
69 Posts
The one from Racechip seems to provide an awful lot of power. However, with their new line of products, they do not show one for the SQ4 (whereas their prior products did cover the SQ4). They do show one for the Levante and I would be willing to bet it would be fine for the SQ4. The new products have adjustable output, whereas mine (previous product) does not offer adjustability, except by disassembling the unit and changing settings on the component board.

Rick
 

·
Registered
Joined
·
281 Posts
Ron, the symptoms you describe (starting and idling fine with stumbling while accelerating), sound like too much fuel; not enough air.

Rick
I hear you. I cleared the codes & tried again. Good idle, but greatly reduced power...like limp mode...then the CEL came back on.

I put the bypass plug back on (mentioned in the other thread) and she's running fine again. Doesn't make sense!

I don't get what the problem is...It's not my car or the connections or I'd have the problem with the bypass plug in also, so????

2nd control box also...
 

·
Registered
Joined
·
324 Posts
The one from Racechip seems to provide an awful lot of power. However, with their new line of products, they do not show one for the SQ4 (whereas their prior products did cover the SQ4). They do show one for the Levante and I would be willing to bet it would be fine for the SQ4. The new products have adjustable output, whereas mine (previous product) does not offer adjustability, except by disassembling the unit and changing settings on the component board.

Rick
They still have the Q4 on the Racechip.com site. It is not listed on the US site.
 

·
Registered
Joined
·
69 Posts
Is it possible that the sensor plugs may be plugged in backwards? I know that with the Racechip harness, it would have been possible to mistakenly reverse the "A" and "B" plugs.

Richard
 

·
Registered
Joined
·
281 Posts
They also said this and asked me to check the cam position sensor to make sure it was orientated properly. I had it correct, so I don't know.

I made sure the "clip" part of the connector went back on same way as the stock one was on the manifold pressure sensor.

I will double check the connectors that plug into the stock connectors & both connections on the boos pressure sensor.

I guess how could I have received 2 bad control modules?
 

·
Super Moderator
Joined
·
2,100 Posts
They also said this and asked me to check the cam position sensor to make sure it was orientated properly. I had it correct, so I don't know.

I made sure the "clip" part of the connector went back on same way as the stock one was on the manifold pressure sensor.

I will double check the connectors that plug into the stock connectors & both connections on the boos pressure sensor.

I guess how could I have received 2 bad control modules?
Did you order a unit specific and up to date for the SQ4? There have been issues with versions that are not specific to SQ4 and later ECU software versions.
 

·
Registered
Joined
·
5 Posts
I hear you. I cleared the codes & tried again. Good idle, but greatly reduced power...like limp mode...then the CEL came back on.

I put the bypass plug back on (mentioned in the other thread) and she's running fine again. Doesn't make sense!

I don't get what the problem is...It's not my car or the connections or I'd have the problem with the bypass plug in also, so????

2nd control box also...
Sigh..why do I mod cars! lol

So I had similar issues. Got the ECM installed today. Really rough idle, then it died. Checked all connections, everything is hooked up correctly. Put in the bypass plug, starts up fine, but feels like a 150hp car. No CELs/codes being thrown/etc. :(

Of course Madness's voice prompt says they're open in CA 9am-4pm PST but the website says otherwise. GAH!
 

·
Registered
Joined
·
5 Posts
I'm tempted to pull the harness and go 100% stock and see if it changes anything (doubtful since the bypass plug should just, well, bypass, if built correctly), but I reallllllyyyy don't want to do that manifold pressure sensor again. Jebus, what a PITA.
 

·
Registered
Joined
·
281 Posts
I'm tempted to pull the harness and go 100% stock and see if it changes anything (doubtful since the bypass plug should just, well, bypass, if built correctly), but I reallllllyyyy don't want to do that manifold pressure sensor again. Jebus, what a PITA.
Did you connect the red and black cables? That solved all of my problems. Also try disconnecting the battery for 20 minutes.
 

·
Registered
Joined
·
9 Posts
I just recently posted a Maserati warranty issue with a motor with an ECU Tune- Maserati says it will void warranty. They will not honor the warranty regarding an issue I recently had with an engine oil pressure problem and loud ticking noise from motor. The ECU tune was installed by dealer a year ago. Need to think about that if you are thinking Tune
 

·
Registered
Joined
·
9 Posts
Careful regarding ECU Tuning!

My Maserati dealer very enthusiastically sold me an ECU tune for 2016 Ghibli. Explained how much of a performance increase I would get. When done, was very excited about their results- told me I would love the new performance. What I was not told was that the warranty would be voided. 1 year later, engine pressure light goes on, and a loud ticking noise coming from somewhere toward underside of motor. Maserati now say they will not honor warranty due to the tune. No one knows for sure what caused the problem because it is not policy to tear motor apart yet as they are just generally replaced by Maserati. Another Maserati rep from different region told me that he know about at least 10 Ghibli motors (S Q4 twin turbo 6) that have been replaced for same reasons (not ECU tuned). Anyone know of any other information about this situation?
 
81 - 100 of 125 Posts
Top