Maserati Ghibli Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1
So my engine light popped on last night. First flashed and then went solid. Car runs perfectly fine. Had an oil change 2000 miles ago (now has 7200 miles). Makes no sense. Was hoping NOT to spend part of my Friday night at the service center. Anyone else have this happen and what did the problem end up being? All temperatures are fine, car runs fine, no indicator that anything is wrong except for the light. Gas cover is sealed properly too.
 

·
Registered
Joined
·
84 Posts
Discussion Starter #3
So much for me paying attention...I had an auto guy fixing some scratches and just had him change the oil at the same time. He works on Maserati and Ferrari. My dumb*** didn't check the manual to know it was 12,500 miles. :)
 

·
Registered
Joined
·
84 Posts
Discussion Starter #6
You would think it would have triggered the engine light a long time ago then, and if it's not due for 12,500 miles (I'm only at 7200) it still isn't time, so I'm thinking it's something else. Will find out tonight.
 

·
Registered
Joined
·
84 Posts
Discussion Starter #7
Well they figured out it was a "CYLINDER 1 MISFIRE." Lovely...they cleared it and said if it happens again, bring it back.
 

·
Registered
Joined
·
36 Posts
So my engine light popped on last night. First flashed and then went solid. Car runs perfectly fine. Had an oil change 2000 miles ago (now has 7200 miles). Makes no sense. Was hoping NOT to spend part of my Friday night at the service center. Anyone else have this happen and what did the problem end up being? All temperatures are fine, car runs fine, no indicator that anything is wrong except for the light. Gas cover is sealed properly too.
I have the exact same symptoms. Flashing light that goes solid. They car is a little sluggish but overall runs OK.

The check engine light came on twice on my 600mile Ghibli Q4. Going to the dealer for the 3rd attempt to fix it. Did you get your fixed?
 

·
Registered
Joined
·
19 Posts
Go to AutoZone or a place like that. They have a handheld reader that plugs in and can tell you what the problem is and then they can even reset it. It happened to me a few months ago and has happened since maybe bad gas.
 
1 - 10 of 10 Posts
Top