Maserati Ghibli Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi guys. First post as I recently purchased a 2014 Ghibli and have a TPMS question. I have read a bunch of threads, but can't find what i need or i am confused..

Is there a TPMS re-learn procedure? I have read the owners manual, forums, etc. The best I can find from advise given is to drive the car for 20 minutes over 20mph or the like.

I have an indicator with the "Service Tire System" alert. All four tires show the correct PSI in the display. BUT when troubleshooting, the F/R tire and R/L tires are flip flopped in the display when adding and removing air.

I have an ATEQ VT15 that will arrive today. But as I research, I feel this may not be all I need to resolve.

Thanks in advance for any help.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #2 ·
Will pulling the battery cable make it relearn the TPMS sensors? I may just go to the dealer and have them do it. I have spent too much time trying to figure it out…
 

·
Registered
Joined
·
652 Posts
I think you should visit the dealer, what you're describing is most likely some fault with one of the TPMS system components.
There is no reprogramming or relearning procedure for the system Ghibli uses, it automatically detects the sensors and their position after a few minutes of driving.


Also, I think you should return the sensor activation tool, I'm afraid you can't do anything with it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Toshy thanks a ton. I was getting there, just needed some assurance. I am going to take both of your suggestions. Thanks. I can see that I may need help here frequently, so I will be sure to update with the resolution. Thanks again.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Went to the dealer and the Mas gods were shining down on me. I found out it is under factory warranty until the 2nd of next month. So the issue will be covered under warranty. I take it in next week. Will reply.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Alright took it in and the sensors weren't communicating with the Unit. They cleared it and then it worked again and they couldn't get it to turn back on. I am highly doubtful, but have to take their word for now. But I did get them to commit to fixing it under warranty if it comes back.

They said my air filters on each side were bad and cleaned them. I told them I would put in my own cabin filter.

I had mentioned a sound to them and they heard it to. There was an issue with a bushing on the front drivers side. They covered that as well.

I paid for the oil change and brake flush.

They gave me a 2018 loaner. Good experience with dealer in Schaumburg, IL.
 

·
Registered
Joined
·
8 Posts
The 14 and 15 Ghiblis had a lot of issues with the TPMs modules. The 18s have been redesigned with new modules and new location for it because they would get damaged or ripped out if the car bottomed out over pot holes or bumps.
 
1 - 7 of 7 Posts
Top