Maserati Ghibli Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi, is anyone else experiencing bluetooth connectivity issues with iPhone?
I have the iPhone 11 with the latest iOS 13.3 but it will only connect with my Ghibli in maybe 1 out of 4 times I drive.
I put the car in the Maserati garage and they said that the car has latest software but they could not diagnose any fault.

Apple store checked my phone and that's all ok too- I have done countless resets on the phone and re-paired it with the car dozens of times but the problem persists.

Is this a compatibility issue? If so, how come it can connect sometimes?
 

·
Registered
Joined
·
215 Posts
My iPhone 11Pro iOS 13.3 on a MY16 SQ4 connects always. But it takes more time to connect, than before (iOS 12).

Did you try to remove the connection in the iPhone and also in the MTC. Cycle power of your iPhone and Ghibli. Then setup again. If it still doesn't connect intermittent, I expect an issue with the BT module on the Ghibli.

Have you tried with another Smartphone?
 

·
Registered
Joined
·
649 Posts
I have the same issue with the iPhone 11 Pro in my '16 SQ4. It connects once in a blue moon, but weirdly it connects as an audio source most of the times.
Unpairing and pairing the phone is also problematic, it works one in five times (after shutting down the car completely), and even if it says "pairing successful" it returns an error message. Quite annoyed with it, especially when this is the 4th iPhone I've used with the car since I got it in spring 2016 (had an 5S back then), and I'm afraid there is no fix as they won't issue a BT firmware update for the car anymore :(
 

·
Registered
Joined
·
11 Posts
Is this site same issue with everyone that has an iPhone 11? Im waiting for my 2015 SQ4, and I already ordered my navtool with CarPlay, and im really hoping this isn't the issue. One of the main reasons I sold my Volvo was because the bluetooth drove me insane.
 

·
Registered
Joined
·
113 Posts
Works every time for me. There is a Facebook poll on this on the Ghibli Group. I suspect maybe it's your poll, but if not, it seems 50/50 on people with and without issues.
 

·
Super Moderator
Joined
·
2,019 Posts
I have the iPhone Xs ... 13.3.1 ... connects without issue. Occasional issue hanging up where I need to pair the phone back to the car, but rare.
 
1 - 10 of 10 Posts
Top