Maserati Ghibli Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Has anyone had difficulty connecting an iPhone 6 to the Ghibli. I am unable to answer incoming calls on the software and also unable to hear the audio on calls placed using the "Phone Book" feature on the car. However, if I manually type the number in all works fine. Hope someone can help.
 

·
Registered
Joined
·
77 Posts
my iPhone 6 is a mess. it dials unknown over and over again. I think I'm the only person who has this issue. i am not able to use blue tooth at all. I also get that awful noise when talking to someone. Hope they come up with a fix soon.
 

·
Registered
Joined
·
117 Posts
Sounds like it may be a problem with the bluetooth hardware on the phone- not software. The software, iOS 8, works fine with my car but with an iPhone 5s.

See if Apple will replace the phone or try a friends iPhone 6 and see if they have the same issue.

Good luck!
 

·
Registered
Joined
·
216 Posts
Sounds like it may be a problem with the bluetooth hardware on the phone- not software. The software, iOS 8, works fine with my car but with an iPhone 5s.

See if Apple will replace the phone or try a friends iPhone 6 and see if they have the same issue.

Good luck!
iOS 8.0.1 and 8.0.2 has some Bluetooth issues. You might want to install 8.1 which should be out know or these days.

However, also 7.1.2 on a 5s is not perfect. But this is a Ghiblic/MTC issue. Siri doesn't work. Sometimes I also cannot answer an incoming call.
 

·
Registered
Joined
·
117 Posts
8.1 just came out. I hope that fixes your problem and the SIRI issue. I have not had the problems answering calls like other people have.
 

·
Premium Member
Joined
·
286 Posts
Has anyone had difficulty connecting an iPhone 6 to the Ghibli. I am unable to answer incoming calls on the software and also unable to hear the audio on calls placed using the "Phone Book" feature on the car. However, if I manually type the number in all works fine. Hope someone can help.
It's an iphone 6/ ios 8 update issue. I had the same issue and even my wife had the same problem with her Range Rover. She called Apple and here is the fix.
Go to your iphone settings ....then hit General ..go all the way to the bottom and hit Reset.... then hit Reset all Settings ( WARNING you may have to reset your e.mail passwords or other accounts that you may have)
After taking care of the above restart your phone and reconnect to MTC.
Hopefully this will take care of your issues.0:)
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Solved

Ok, so I have not updated to 8.1 yet, however, I did some research on the UConnect system as a whole.

To fix the problem, delete the device from your Ghibli's bluetooth settings (be sure to unpair it as an audio source too.) Next go to your iPhone 6. Open your "Settings" > "General" > "Reset" > "Reset Network Settings".


Then pair your phone to your Ghibli again. Once connected successfully do a hard reset of your phone. For those that don't know, hold the home button and the lock button of your phone at the same time and all should work perfectly.
 

·
Administrator
Joined
·
1,301 Posts
I have an iphone 6, just recently got it about 2 weeks ago. I have ZERO issues with using the phone or Bluetooth with the MTC system.

if you are having issues, the first thing you want to do is remove the device from the MTC memory, also remove the MTC from the phone, so basically start fresh from both the phone and the car.

make sure your iphone is up to date, settings, general, software update. the latest version should be 8.1.1.

once your phone is up to date, reinstall the connections between the MTC and iphone.
 
1 - 9 of 9 Posts
Top