Maserati Ghibli Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I thought I'd throw this out there as my first post hoping someone might have some sage advice to share. I have been driving a 2017 Ghibli S since January. I have never had a problem with connecting my Samsung S5, including uploading call history, contacts, etc. until just recently. I have also had my stepdaughter's iPhone 8 successfully paired and have played music through audio as well. Typically, it had always reset back to my phone as the default ... both for phone and audio. No problems then. Now, MTC+ doesn't want to pair with my phone at times ... regardless of how many times I've deleted and repaired or turned on and off my phone. And when it does sporadically pair, forget about the contacts and call history rendering the phone's hands-free feature useless. Does anyone have any experience with this? Is there a way to reboot and get the settings back to where they were originally? Pretty frustrating!
 

·
Registered
Joined
·
322 Posts
I thought I'd throw this out there as my first post hoping someone might have some sage advice to share. I have been driving a 2017 Ghibli S since January. I have never had a problem with connecting my Samsung S5, including uploading call history, contacts, etc. until just recently. I have also had my stepdaughter's iPhone 8 successfully paired and have played music through audio as well. Typically, it had always reset back to my phone as the default ... both for phone and audio. No problems then. Now, MTC+ doesn't want to pair with my phone at times ... regardless of how many times I've deleted and repaired or turned on and off my phone. And when it does sporadically pair, forget about the contacts and call history rendering the phone's hands-free feature useless. Does anyone have any experience with this? Is there a way to reboot and get the settings back to where they were originally? Pretty frustrating!
Interesting never happened to me since i got my car.
Might be the phones? Try to restore it and retry.
 

·
Registered
Joined
·
1 Posts
I thought I'd throw this out there as my first post hoping someone might have some sage advice to share. I have been driving a 2017 Ghibli S since January. I have never had a problem with connecting my Samsung S5, including uploading call history, contacts, etc. until just recently. I have also had my stepdaughter's iPhone 8 successfully paired and have played music through audio as well. Typically, it had always reset back to my phone as the default ... both for phone and audio. No problems then. Now, MTC+ doesn't want to pair with my phone at times ... regardless of how many times I've deleted and repaired or turned on and off my phone. And when it does sporadically pair, forget about the contacts and call history rendering the phone's hands-free feature useless. Does anyone have any experience with this? Is there a way to reboot and get the settings back to where they were originally? Pretty frustrating!
- iPhone 8 is still not in market - //I think it’s a typo
- When we click on “Unpair” or “Forget network” on some Android phones typically it comes to “Available Devices” even though the device is not in Range (Pairing may fail in this case). Better way to try is Re-scan and find the device and pair it.
- Deleting all paired Devices both on Phone and MTC should help
- Hard Reset/Factory settings reset on phone should also work.
- Try Restore Settings MTC also if nothing worked.
 

·
Premium Member
Joined
·
583 Posts
I just found something i did not know.

I was driving with my daughter and she wanted to make me listen to some songs on her phone, so went into the MTC+ Bluetooth settings and my phone was already connected, and then we tried only to set the Bluetooth for her phone on AUDIO only, and it works.

I received phone calls on the car, and as soon the call was ended, the music from my daughter's phone just keep playing as normal
it is a features i never tried before
 
1 - 6 of 6 Posts
Top