Maserati Ghibli Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
I was hoping someone has had similar issues and can tell me how it got fixed.

About a year ago Maserati replaced the radio due to an issue with SAT radio not connecting on my 2015 Ghibli. A few months after that I started experiencing intermittent Bluetooth connectivity issues which got progressively worse to the point where my phone would only connect via Bluetooth less than 20% of the time. Last week my dealer changed out the Bluetooth module and all was good in the world with good, fast reliable connections. Fast forward four days and were right back to the same symptoms as before.

Now my dealer is saying they are happy to look at it again but that Maserati doesn't support phones older than iPhone 6. I think that is complete BS as all newer phones are also backwards compatible with the older version of Bluetooth. Also, no phone seems to connect when it's doing this regardless age, make or model. My new phone has no issues connecting with my 2015 Toyota or the 2009 Mercedes so I find it odd that Maserati would only support connections for phone made in 2015 or earlier.

My dealer has been great and i'm sure it will get sorted out eventually but I wanted to reach out to this group to see if anyone experienced anything similar even after the Bluetooth module was replaced. What was the final resolution? Something seems to be causing the Bluetooth module to crap out.

I never realized how much I relied on my hands free setup until it stopped working. For the most part I love my car especially the way it's spec'd out with all the upgrades but this Bluetooth thing may force me to look elsewhere.
 

·
Registered
Joined
·
65 Posts
Sadly after iOS 13.1.2 things progressively stopped working. I’ve been to the dealer multiple times, even had them update the BT module to the latest firmware with no avail. Until FCA updates their firmware again (which I doubt they will since this UConnect is so old) the BT will remain broken for newer devices.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #4
Thanks AlphaWIP. The issue seems to be with all phones, not just iphones on 13.1.2 or higher. When it acts up even Androids won't connect.
 

·
Registered
Joined
·
65 Posts
Thanks AlphaWIP. The issue seems to be with all phones, not just iphones on 13.1.2 or higher. When it acts up even Androids won't connect.
I have an old HTC 10 with an older Android (Nougat?) that could connect every single time without fuss, which is why I suspect it’s an issue with newer phones.
 
1 - 5 of 5 Posts
Top