Maserati Ghibli Forum banner
1 - 20 of 62 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
I am facing radio issues - both AM/FM or iphone through the hardwire. Many times I don't hear anything even though the radio is ON. Is goes away automatically and I starts hearing sound. :(

Did anyone face these issues? If yes, how was this fixed?

Thanks
 

·
Registered
Joined
·
283 Posts
I've experienced it once when i started the car and couldnt hear anything coming out of the car. I had to restart the car. Ive yet to experience the same problem.
 

·
Registered
Joined
·
216 Posts
I also experience this occasionally. But can't reproduce. Usually it comes after a minute or so.
 

·
Registered
Joined
·
206 Posts
Originally Posted by garry28I am facing radio issues - both AM/FM or iphone through the hardwire. Many times I don't hear anything even though the radio is ON. Is goes away automatically and I starts hearing sound. :(

Did anyone face these issues? If yes, how was this fixed?

Thanks
Hi gary28,

My name is Howie from MaseratiCares - MNA's official online customer service manager.

The new amplifiers were upgraded with new software. The current MNA solution is to replace the amplifier. The campaign was issued in Sept-Oct to upgrade software with no replacement of AMP.

The latest software was introduced into production on 6/14/2014. The New software reduces Bass Curve too much, where there is a reduction in overall quality of sound.

MNA is now working to validate new software that re-introduces an active bass curve.

Regards,

Howie - MaseratiCares
 

·
Registered
Joined
·
666 Posts
Hi Guys

I may have experienced the same issue this morning.
I turned the car on and there is no sound. I turned the volume up, changed it to all different sound sources. NOTHING. I stopped at the stop light and turned the car off, started it again. Still nothing.
If there something I can do to take care of this myself? I would hate to go into the dealer again. I have been there at least 8-9 times since I got the car back in July 2014
 

·
Registered
Joined
·
14 Posts
Now that it's cold, I'm having this problem again. Last winter, the same probs as reported. Start car, no sound. Parking sensors, radio, zip. Have to turn off car, wait , restart after all electrical stops. Usually works. But never comes on on its own. Last winter dealer looked at stuff extensively, couldn't replicate. That's the frustrating part. I can't either. But it's more freq when cold. Help! Frustrated.
 

·
Registered
Joined
·
109 Posts
I had this happen once, though it was not cold out. Stopped, turned the car off, opened the door so the radio shut down, and waited 15 seconds. When I restarted everything was fine and it hasn't recurred. I have the B&W, so it is not specific to the premium sound system...
 

·
Registered
Joined
·
160 Posts
Howie,
I do hope a software fix solves the bass issue. As you may know, the sound coming from my "premium sound system" is not premium. The subwoofer in my Ghibli is totally worthless. Hope you guys can fix this deficiency.
 

·
Registered
Joined
·
666 Posts
Howie,
I do hope a software fix solves the bass issue. As you may know, the sound coming from my "premium sound system" is not premium. The subwoofer in my Ghibli is totally worthless. Hope you guys can fix this deficiency.
Good luck with that. Dealer performed the Dynamat "fix" 3 times, which improved a little, but when the temp drops, it got worse than before. The word on the street is that Maserati has no fix for it.
I wonder if that can be considered a defect and used in Lemon law....
then they will have to replace every single car. ha ha
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #11 ·
Howie - even after the amplifier replacement, it's a gamble. Most of the times iPhone doesn't work through the UBS port. Radio is ok 8/10 times.

Would you know if there is any temp fix while Maserati is working on a perm one?

Thanks


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
30 Posts
i had the same issue. Start the car, no sound, restart no sound, restart sound... I brought the car in when there was no sound so they could see it for themselves. They replaced the amp, I now have sound 100% of the time, but it sounds like it is coming out of a tin can. No bass, and unlistenable with music, I go with talk radio or nothing. Brining it back this week. Again. Oh, and the subwoofer rattle is worse with the lower temps as well.
 

·
Registered
Joined
·
283 Posts
Today, i woke up to no audio sound from my system. I tried restarting the car, twice!, still nothing. I'll try again on my break and see if it will come back on.
 

·
Premium Member
Joined
·
286 Posts
I had same issue where I couldn't hear anything out of the sound system. No sensor beeps either. I took it in to my dealer and they are looking into it. The sound came back after I re started the car few times. I will let you guys know what they end up fixing.
 

·
Registered
Joined
·
206 Posts
Originally Posted by garry28Howie - even after the amplifier replacement, it's a gamble. Most of the times iPhone doesn't work through the UBS port. Radio is ok 8/10 times.

Would you know if there is any temp fix while Maserati is working on a perm one?

Thanks


Sent from AutoGuide.com Free App
Hi garry28,

There is a permanent improvement for this. I would advise you take your Ghibli to your local authorized dealership for further investigation and improvements.

Thanks,

Howie - MaseratiCares
 

·
Registered
Joined
·
160 Posts
Howie,
Can't wait for Maserati to correct the lack of bass issue. When can we expect this to happen? Thanks, Scott from Tampa
 

·
Registered
Joined
·
28 Posts
Count me as having the no sound issue as well. Seriously, at this point almost every 2014 owner has the same list of 5-10 problems. How has Maserati not sent a message to everyone to bring their cars in to fix all of these issues. If it wasn't for this website, no one would ever know there are fixes and the Ghibli is not just some inferior import.

I love the car, but seriously, get your service and communication act together Maserati NA.
 

·
Registered
Joined
·
123 Posts
For what it's worth, don't think these radio / iPhone issues are exclusive to Maserati.

A co-worker of mine bought a 2014 Audi A7 about 5 months ago. He's had it at the Dealer 4 times for iPhone compatibility issues as well as radio and sat nav reception problems.

I was also having problems with my iPhone 6 with my Ghibli, including losing Siri functionality, but after reading some others' fixes as posted on this forum, I got it to work perfectly.

Who woulda thought we'd have to be part I.T. guys to operate our dang cars properly!
 

·
Registered
Joined
·
695 Posts
Whenever I've had to bring the car in, not lately, my dealer performs every fix and upgrade not already done. This was the same case with my SLK55, which had no problems for 2 years!
 

·
Registered
Joined
·
11 Posts
I also experience the same problem on 2015 model, start the car and no sound. Need to wait till the car warm up, then restart to get the sound back.
 
1 - 20 of 62 Posts
Top