Maserati Ghibli Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi is anyone having issues with the radio? For the 3rd time, my car radio will not work, it shows its on i tried fm, sat, cd nothing worked, but it would show on the screen that it was on and volume would go up in number, bu NO SOUND!!! :( the weirdest part is on the way home for the last 2 days it works fine.... It looks like its the radio amp, becasue not even sound for the phone blue tooth or parking sensors would work..
 

·
Registered
Joined
·
3 Posts
Hi AGMIA,

I have a 2014 Q4 S that has the same issue. There are sound about 50% of the time when I start the car, and the other 50%, I hear nothing from the radio, CD player or phone, but the climate control works and all other controls are fine. My dealer in Charlotte, NC says it is the 'amplifier' and has ordered a new one from Italy. I don't know what an amplifier is, but it sounded like my dealer knew this righ-away without even seeing the car (we talked over the phone). So, you can ask your dealer if they know if this is the issue in your car also...
 

·
Registered
Joined
·
114 Posts
In talking with my dealer today about the issues I am having with satellite radio drop outs, he said that the amp is actually a Bowers & Wilkins amp. I had no idea they made amps - I thought just speakers? Apparently all 3 versions of the sound system are OEM from B&W. Anyway, I'm getting a new amp/head unit because of the satellite issue. The dealer said they have already replaced one other customers so apparently there are known problems with the amps. He also said they would "reseat" and seal the subwoofer speaker so hopefully that will improve the sound quality. Honestly if I were B&W, I would not want my name associated with the current quality of the sound in the car. My kid's boom box sounds better than this!
 

·
Registered
Joined
·
8 Posts
Counted the number of times acquiring signal popped up on trip from mass to NYC. Stopped when I got to 100. Frustrated.
 

·
Registered
Joined
·
22 Posts
In talking with my dealer today about the issues I am having with satellite radio drop outs, he said that the amp is actually a Bowers & Wilkins amp. I had no idea they made amps - I thought just speakers? Apparently all 3 versions of the sound system are OEM from B&W. Anyway, I'm getting a new amp/head unit because of the satellite issue. The dealer said they have already replaced one other customers so apparently there are known problems with the amps. He also said they would "reseat" and seal the subwoofer speaker so hopefully that will improve the sound quality. Honestly if I were B&W, I would not want my name associated with the current quality of the sound in the car. My kid's boom box sounds better than this!
your dealer is way off base with the satellite fix... are you sure thats what they are going to do? Its an antenna issue not a head unit or amp issue. On mine they just needed to replace the antenna with a different one and the problem is gone. I also had that subwoofer fix performed on my car it makes it a little better but not much. The problem with the sub and the entire system is its just junk. How they could of put such sub-par product in this car is embarrassing.
 

·
Registered
Joined
·
324 Posts
The problem with the sub and the entire system is its just junk. How they could of put such sub-par product in this car is embarrassing.
It's one of the cost cutting measures to keep the price lower. Either you accept that if you want the low price or you believe Maserati should properly outfit the ghibli and raise the price accordingly. I'm of the latter camp.
 

·
Registered
Joined
·
284 Posts
i rather they cheap out on the audio system than any other part of the car.
plus i never like factory audio systems, rather install something more to my liking
 

·
Registered
Joined
·
22 Posts
then they shouldn't charge extra for it and call it a "premium" system if its the "cost-cutting" system. That doesn't make sense. I've rented sub 20k economy cars before with way better stereos. I don't believe they meant for it to be this poor.
 

·
Registered
Joined
·
87 Posts
Satellite Radio Fix

Heard from my service advisor today that there is a fix expected to be out in early March.

I would suggest that anyone who is experiencing the satellite dropping should contact their service advisor so that they can be informed when the fix is available.

I will post when I have more information.

For those who have yet to take delivery or have yet to decide to purchase, I would take comfort that the dealerships (at least Maserati of Washington) are working very hard to satisfy their customers.
 

·
Registered
Joined
·
284 Posts
Thanks for the info. I haven't bought one yet but I know some people who have, waiting for a "safe" time to buy in.
 

·
Registered
Joined
·
114 Posts
your dealer is way off base with the satellite fix... are you sure thats what they are going to do? Its an antenna issue not a head unit or amp issue. On mine they just needed to replace the antenna with a different one and the problem is gone. I also had that subwoofer fix performed on my car it makes it a little better but not much. The problem with the sub and the entire system is its just junk. How they could of put such sub-par product in this car is embarrassing.
You are right about the dealer being off base on the head unit. When I described the problem again to them, they agreed that it is the antenna. I am curious how you got that fixed because they claimed (last week) that Maserati does not yet have an approved fix for the issue. Do you know what they did so that I can try to describe it to my dealer?
 

·
Registered
Joined
·
22 Posts
You are right about the dealer being off base on the head unit. When I described the problem again to them, they agreed that it is the antenna. I am curious how you got that fixed because they claimed (last week) that Maserati does not yet have an approved fix for the issue. Do you know what they did so that I can try to describe it to my dealer?
When my car was at the dealership for over a week getting the subwoofer re-set and re-insulated into the back of the car they ended up fixing the Satellite issue as well. Apparently, there was a Maserati Corporate guy there at the time and he authorized them to order me a new antenna. It came the next day and they removed the old antenna and replaced it with this new flatter antenna. I believe they had to access the interior roof lining of the car to replace some of the wiring and complete the install. It absolutely did the trick! I get solid reception now, NO drop offs hardly ever. One thing was they installed it as a standard black antenna. I believe there intention is to be able to paint them per the color specs of your Ghibli, in my case white. They are still supposed to follow up with me once they had a solution to be able to paint the antenna and not effect reception. I told them I didn't mind the black antenna for the time being one bit and agreed to live with it so long as it resolved the reception issue. Perhaps they are still working on that aspect of it and won't be issuing a company wide fix until they have that part of it down?
 

·
Registered
Joined
·
14 Posts
Sound Still Mysteriously Disappears

This thread started with the problem of "sound" not coming on. From anything on start up. No radio, no auxiliary, no sound from parking warning system, phone, etc. If the car were turned off and sat a while, usually 3-5 minutes after complete shut down, everything worked as normal. Dealer checked software update of the amp--it had been updated--, a connector beneath the driver's floor mat that can be corrupted with moisture (a terrible place for same), and a connector in the pillar to no avail. After dealer problem solving attempts, I'm to keep track of circumstances. In 2 weeks, 4 events, 3 starting up from satellite radio on, 1 from iPod being on. Whether starting from back up or moving forward, can't identify pattern. Thoughts?
 

·
Registered
Joined
·
5 Posts
This happened to me today for the first time. I've been having a different issue with my audio prior to today. What's been happening to me, is I start the car and the volume is at max. I try and turn it down, but as fast as I turn it down the car tries to increase the volume. Usually if I restart the car it will stop. But, today I had the no audio issue. Tried restarting the car half a dozen times, but to no avail. I wasn't able to let the car sit for any length of time because I had to get to work. Hopefully there is a software update or something soon to fix these issues.

I've searched a lot about the UConnect system in other cars and there have been similar issues that seemed to have been fixed by software updates. Fingers crossed.
 

·
Registered
Joined
·
1 Posts
Did this work? I've had my Ghibli for a couple months and have been complaining to my local dealer about this ongoing issue. Apparently he was not aware of any issues and wasn't sure what the problem was. I finally brought it in for a service and they told me they ordered a new amp and it would be installed in the morning. Fully aware of the issue. Did it solve your problem?
 

·
Registered
Joined
·
159 Posts
This happened to me today for the first time. I've been having a different issue with my audio prior to today. What's been happening to me, is I start the car and the volume is at max. I try and turn it down, but as fast as I turn it down the car tries to increase the volume. Usually if I restart the car it will stop.
This sounds like a sticky volume switch. Check the rockers on the back of the steering wheel to see if they are stuck in an up or down position. I had a similar thing happen to me on a radio I was installing in one of the previous cars. When I put the unit in, I accidentally pushed on a button which was left in a stuck position. It was relatively simple to loosen it again.
 

·
Registered
Joined
·
1 Posts
sound system

I have read all the threads and can say a number of things on point. 1) I have owned B&W at home and it is superb. I would not want my name associated with Maserati either. It sounds awful in this car. 2) I have driven Mercedes for 15 years, and the Harmon Kardon blows this system out of the water. I have the Ghibli SQ4 and the MB CLS 550. The CLS is hands down the best sound system. The sound is rich and full, and the bass is second to none. The Ghibli sounds like the trunk is coming loose with all the rattling. I had the dealer add a dynamat to the rear shelf, and it helped a little (I stress a little). 3) The worst part is the sound when I have a call on bluetooth. I have to turn the volume so low to avoid the crackling that I cannot hear the caller. Again, I never had an issue with MB, including the after market systems I added on the earlier models. 4) About 80% of the time, the sound system shows it is working, but it is not. 5) About 90% of the time the drivers window does not roll up.

6) And this is my main point, the dealer says it needs a software update. They have had my car more in the 4 months I have owned it than I have eaten dinner. Nothing they do fixes anything. That being said, I love this car, the way it drives, and the looks it gets.

On a final note to the person who said he/she would vote to have the price raised: the B&W option was a lot extra! When I paid for this with MB, I got what I paid for.
 

·
Registered
Joined
·
292 Posts
They have had my car more in the 4 months I have owned it than I have eaten dinner. Nothing they do fixes anything. That being said, I love this car, the way it drives, and the looks it gets.
We are in the same boat. I purchased my car on April 30th and LOVE the car, as well. However, today marks the 14th day that I have been without it..... My frustration is starting to become permanent.
 
1 - 20 of 27 Posts
Top