Maserati Ghibli Forum banner
1 - 9 of 9 Posts

·
Registered
2017 Ghibli base
Joined
·
6 Posts
Discussion Starter · #1 ·
The rear view camera on my 2017 base model just started switching between blue screen and normal view on the MTC+. I cannot see a pattern but sometimes when I put it in reverse the screen is blue and sometimes it works fine. The screen can turn blue 5 minuter after the camera / screen worked fine.
Any advise on how to trouble shoot the problem?
 

·
Registered
Joined
·
5 Posts
I had a similar issue on my 2019 and it was the camera in the trunk. First it was a scrambled up picture when going into reverse and then solid blue. I believe it's a known issue with the wiring at the camera in the trunk lid. My camera was replaced under warranty. I hope this helps.
 

·
Registered
2017 Ghibli base
Joined
·
6 Posts
Discussion Starter · #3 ·
ENelsonMaserati - thanks for reply. My Ghibli is '17 and I will not be able to fix this under warranty...unfortunately. Might start by taking the trunk molding off and see if just reconnecting the wiring resolves the problem with the camera going on and off.
 

·
Registered
2017 Ghibli base
Joined
·
6 Posts
Discussion Starter · #5 ·
Hi Isg299, I have tried to reconnect the camera in the truck to check if wiring was coming loose. Did not seem to be the problem and I have concluded to replace the camera and now need to find a place to purchase one not too expensive. What are your thought about the cause of the problem?
 
1 - 9 of 9 Posts
Top