Maserati Ghibli Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey Guys,


Anyone else experiencing this? Swapped out 18" stocks for 20" Vossens. Installed OEM sensors on the wheels and car is reading the pressure ok. One problem, still giving me a "service TPS system". Took it to the dealer and of course once they see the aftermarket rims they automatically wash their hands.


They did a reset on the system and increased the sensor gain but 100km later it all came back again.


I find it hard to believe its the tires since the car is showing me all the tire pressures.


Anyone else with this??
 

·
Registered
Joined
·
172 Posts
if the sensor reads the pressure is not a faulty sensor but this did not happen to me when I replaced my sensors with different wheels. When I did that the car recognized them on the fly. When you go to the screen and see the pressure try to hold the arrow and see id something happens...just my 2 cents
 

·
Administrator
Joined
·
1,301 Posts
Hey Guys,


Anyone else experiencing this? Swapped out 18" stocks for 20" Vossens. Installed OEM sensors on the wheels and car is reading the pressure ok. One problem, still giving me a "service TPS system". Took it to the dealer and of course once they see the aftermarket rims they automatically wash their hands.


They did a reset on the system and increased the sensor gain but 100km later it all came back again.


I find it hard to believe its the tires since the car is showing me all the tire pressures.


Anyone else with this??
Who did the reset on the system? the dealer or the tire shop?

You can 100% install the TPMS units on any wheel, there is no difference. All the computer is doing is reading the frequency from the unit. Stock sensor, stock computer, stock car, the tire and wheel does not matter.

My guess is the one of the TPMS sensor units was installed improperly.

Who mounted the sensors to the wheel, you or the shop? They MUST be installed using a torque wrench (measuring in inch lbs). If you dont use a torque wrench they could be over / under tighten and if the sensor is even remotely loose you wont get an accurate read because its moving around.

Take the wheels back off, remove the tires and check the sensors, re-install, re-tighten using torque wrench to proper specs. Mount the tires and wheels back on the car and then re-calibrate the sensors to the computer. They should automatically register, a trip to the dealership is not needed. I am certain the sensor was installed improperly though.

You should be able to go online and download the instructions and torque specs. Most auto MFG's use Beru sensors. Go on the Beru website for specs.
 

·
Registered
Joined
·
49 Posts
My guess is the one of the TPMS sensor units was installed improperly.

Who mounted the sensors to the wheel, you or the shop? They MUST be installed using a torque wrench (measuring in inch lbs). If you dont use a torque wrench they could be over / under tighten and if the sensor is even remotely loose you wont get an accurate read because its moving around.


You should be able to go online and download the instructions and torque specs. Most auto MFG's use Beru sensors. Go on the Beru website for specs.

I recently purchased Maserati OEM TPMS sensors to install in a set of 20" wheels for my wife's Ghibli. It appears Maserati is using a Schrader TPMS sensor.

SCHRADER REGION
 
  • Like
Reactions: atrinh

·
Registered
Joined
·
64 Posts
May I enquirer as to which Vossen wheel you decided upon?
 

·
Registered
Joined
·
76 Posts
I am facing the same issue with TPS Service light constantly coming after 200 miles of driving. This is the 5th time the light has come on and the car is at the dealership. The reason for the TPS light per the factory is that my car has ceramic tints and thats causing the issue, but i have had this tint a week after since i purchased the car. The TPS issue happened only when i replaced the winter tires to summer tires and that too from the authorized dealership.

Maserati has changed all 4 wheel sensors as well and put brand new ones, yet the light is still coming on.
 

·
Registered
Joined
·
294 Posts
I am facing the same issue with TPS Service light constantly coming after 200 miles of driving. This is the 5th time the light has come on and the car is at the dealership. The reason for the TPS light per the factory is that my car has ceramic tints and thats causing the issue, but i have had this tint a week after since i purchased the car. The TPS issue happened only when i replaced the winter tires to summer tires and that too from the authorized dealership.

Maserati has changed all 4 wheel sensors as well and put brand new ones, yet the light is still coming on.
Who the heck tell you because of your ceramic tint is completely being idiot and lie to you. how the heck a window tint affect tire sensor? you may ask him that question and see what is his explanation @yangpei: I look in their website and didn't find the Ghibli there. probably they use the same sensor with the chrysler 300. I wouldn't be surprise if that is the case.
 

·
Administrator
Joined
·
1,301 Posts
I am facing the same issue with TPS Service light constantly coming after 200 miles of driving. This is the 5th time the light has come on and the car is at the dealership. The reason for the TPS light per the factory is that my car has ceramic tints and thats causing the issue, but i have had this tint a week after since i purchased the car. The TPS issue happened only when i replaced the winter tires to summer tires and that too from the authorized dealership.

Maserati has changed all 4 wheel sensors as well and put brand new ones, yet the light is still coming on.
window tint has no effect on TPMS, that was the dumbest thing i have heard in a very long time. pure stupidity, even common sense would tell you that.

if you car is at a maserati dealer than they should have the correct TPMS sensors in the wheel. if you are at a non maserati dealer, than its possible they are using the wrong TPMS, many aftermarket dealers are currently selling the wrong unit.

in addition, there are 2 units that will work. one is a direct OE replacement. the other is a universal replacement that must be physically programmed to your car.

the correct unit is:

part # 670002790 (made by schrader)

it is a plug and play device. all you have to do is mount it to the wheel and the sensor will automatically find the signals. you dont have to reset or do anything special.
 

·
Registered
Joined
·
11 Posts
I'm sorry that this is an old issue but I just swap my 18" with 20" Forgiato and my TPMS fail, it shown the correct pressure but with a fault signal and the yellow light on. The new rims has the original OEM sensors. When I switched back to the OEM wheels the system work fine..The dealer check the system and claimed that the TPMS don't work with aftermarket wheels. I do not have tinted windows
 

·
Administrator
Joined
·
1,301 Posts
Tpms works fine in aftermarket wheels. Some wheels have 2 air stems so make sure the tpms was mounted in proper hole and torqued to the correct pressure. After that the car should read them automatically. Sometimes you may have to drive a few miles for it to get a proper reading and reset.
 

·
Registered
Joined
·
11 Posts
It work fine after 3 miles ,then after 3 weeks and more than 200 miles the system failed, the dealer reset the tpms twice and the 3rd time they said no more work under warranty until we swapped back to the original OEM wheels. After we did the swapping the TPMS start working fine after few miles without any dealer reset.
Any body with Forgiato wheels here?
 

·
Registered
Joined
·
89 Posts
I had the problem once on my winter rims - they were fine then one day the TPMS light came on (they are aftermarket rims). Took it to the dealer, and they said they widened the frequency response of the receiver in the car and I haven't had the problem since (and that was over a year ago).
 

·
Registered
Joined
·
294 Posts
My TPS light keep turning on/off randomly. after few days, it would turn on, and turn off by itself after few days again. it has been that way for 2 months
 
1 - 18 of 18 Posts
Top